g5bsd/configuration.nix
2024-08-06 11:39:03 +01:00

37 lines
746 B
Nix

{ pkgs, config, lib, ... }:
{
imports = [
./aprs.nix
];
environment.systemPackages = with pkgs; [ alsa-utils vim git direwolf ];
security.sudo.extraRules= [
{ users = [ "jim" ];
commands = [
{ command = "ALL" ;
options= [ "NOPASSWD" ];
}
];
}
];
services.openssh = {
enable = true;
settings = {
PasswordAuthentication = false;
};
};
networking.hostName = "g5bsd-1";
users = {
users.jim = {
isNormalUser = true;
extraGroups = [ "wheel" ];
openssh.authorizedKeys.keys = [
(builtins.readFile ./jim-ed25519.pub)
];
};
};
networking = {
interfaces."eth0".useDHCP = true;
};
system.stateVersion = "24.05";
}